Degraded Self-Service Merchant Sign Up
Incident Report for Affirm
Resolved
This incident has been resolved.
Posted Aug 05, 2022 - 15:29 PDT
Monitoring
We have implemented the fix and have seen healthy activity for the affected service since the last update. We will continue to monitor and ensure that the functionality remains available.
Posted Aug 05, 2022 - 15:05 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 05, 2022 - 14:35 PDT
Identified
We are aware of an issue with our self-service flow for new merchants to sign up with Affirm. We have identified the cause and are in the process of rectifying now.
Posted Aug 05, 2022 - 14:34 PDT
This incident affected: Affirm.com (US).