Users unable to signup with Affirm in CA
Incident Report for Affirm
Resolved
We are no longer seeing the timeouts. Users in Canada are able to sign-up with Affirm.
Posted Nov 25, 2022 - 17:09 PST
Identified
Some new Affirm users in Canada are unable to sign up with Affirm due to request timeouts.

We are investigating a solution now.
Posted Nov 25, 2022 - 15:12 PST
This incident affected: Affirm Checkout (Canada).