Issue Affecting Customer Loan Repayment and Savings Product
Incident Report for Affirm
Resolved
This issues has been resolved by our 3rd party service provider and we have seen our services return to their usual performance.
Posted May 25, 2022 - 12:24 PDT
Monitoring
The 3rd party service provider has mitigated the issue and our service is recovering. We will monitor the situation until they report that the issue is resolved.
Posted May 25, 2022 - 09:38 PDT
Identified
Disruption to customers' ability to add new ACH payment instruments to service their loans and interact with their savings account has been identified. This is due to a failing 3rd party dependency. We are monitoring their efforts to restore their service and will continue to provide updates.
Posted May 25, 2022 - 08:26 PDT
This incident affected: Affirm.com (US) and Affirm Mobile App (US).