Increased Errors Across Multiple API Endpoints
Incident Report for Affirm
Resolved
The errors have subsided and our services have returned to their usual performance.
Posted Aug 09, 2022 - 08:54 PDT
Monitoring
We implemented a fix and have seen a recovery across all API's. We will continue to monitor the situation to ensure that our systems are fully operational.
Posted Aug 09, 2022 - 08:42 PDT
Investigating
We are still experiencing elevated error rates across our APIs, affirm.com, and mobile app after the previous fix deployment. Our engineering team is continuing to investigate the issue. We will provide additional updates as we know more.
Posted Aug 09, 2022 - 07:57 PDT
Update
We are continuing to monitor for any further issues.
Posted Aug 09, 2022 - 07:35 PDT
Monitoring
Our engineering team has deployed a fix and we are seeing the errors subside. We are monitoring the API endpoints to ensure the issue has been resolved.
Posted Aug 09, 2022 - 07:10 PDT
Investigating
We are currently seeing in increase in 500 response across multiple API Endpoints. Our engineering team is investigating the issue. We will continue to provide updates until the issue is resolved.
Posted Aug 09, 2022 - 06:55 PDT
This incident affected: Affirm Checkout (US, Canada), Affirm.com (US, Canada), Affirm Virtual Card Network (US, Canada), Affirm Mobile App (US, Canada), Affirm Promotional Services (US, Canada), Affirm Purchase API (US, Canada), Affirm Transactions API (US, Canada), and US - Platforms / Payment Gateways (US - Shopify Payments App).