Checkout Performance Degraded
Incident Report for Affirm
Resolved
This incident has been resolved
Posted Jul 22, 2021 - 17:00 PDT
Investigating
We are currently investigating what is causing the degradation to checkout performance
Posted Jul 22, 2021 - 16:37 PDT
This incident affected: Affirm Checkout (US).