Affirm Checkout Disruption
Incident Report for Affirm
Resolved
The issues within the Affirm checkout flow have been mitigated as of 11/17/2021 15:15 PM PST, following our failover of the impacted database servers. We will continue to monitor the situation and relay any relevant communications to our status page.

Our investigation found that a single database instance had become slow to respond and required us to manually redirect requests to back-up systems yesterday. Following resolution of this incident, our engineering team has focused on building the ability to trigger a fallback within minutes and with less disruption to services in the future; we've already added this ability for the impacted system.

We are also closely examining reasons for the sudden slowdown and will have a more detailed analysis in the coming week.
Posted Nov 17, 2021 - 15:51 PST
Monitoring
We've implemented a fix are starting to some successful Affirm checkouts and are now monitoring for stability. We will continue to provide updates as we work towards full resolution
Posted Nov 17, 2021 - 15:10 PST
Update
The solutions we are currently working on are expected to take place within the next hour. We will continue to share updates as we see progress towards resolution.
Posted Nov 17, 2021 - 14:52 PST
Update
We are continuing to monitor and test potential solutions to alleviate the disruptions on the Affirm checkout flow. We will continue to provide updates towards resolution every 15 minutes.
Posted Nov 17, 2021 - 14:37 PST
Update
We are continuing to monitor and test potential solutions to alleviate the disruptions on the Affirm checkout flow. We will continue to provide updates towards resolution every 15 minutes.
Posted Nov 17, 2021 - 14:13 PST
Update
We are continuing to monitor and test potential solutions to alleviate the disruptions on the Affirm checkout flow. We will continue to provide updates towards resolution every 15 minutes.
Posted Nov 17, 2021 - 13:54 PST
Update
We are currently monitoring and testing potential solutions to alleviate the disruptions on the Affirm checkout flow. We will continue to provide updates towards resolution every 15 minutes.
Posted Nov 17, 2021 - 13:40 PST
Update
As we are continuing to see a disruption to the Affirm checkout flow, we are working on different solutions to reduce errors and make the checkout service available again. We will continue to provide updates towards resolution every 15 minutes.
Posted Nov 17, 2021 - 13:24 PST
Update
We are continuing to see a disruption to the Affirm checkout flow. We are working towards identifying a solution and will continue to provide updates.
Posted Nov 17, 2021 - 13:06 PST
Update
We are continuing to investigate a disruption to the Affirm checkout flow. We are actively working on resolving this issue and will continue to provide updates.
Posted Nov 17, 2021 - 12:49 PST
Investigating
We are currently investigating an issue that is affecting the Affirm checkout flow. We will continue to provide more updates here every 15 minutes as we continue our investigation.
Posted Nov 17, 2021 - 12:34 PST
This incident affected: Affirm Checkout (US) and Affirm Charges API (US).