Checkout Performance Degraded
Incident Report for Affirm
Resolved
The incident has now been resolved
Posted Jun 15, 2021 - 16:55 PDT
Update
We are currently seeing an estimated 40%-45% of checkout failures. We are investigating and will update once we have more information
Posted Jun 15, 2021 - 16:50 PDT
Investigating
We are currently seeing an estimated 10%-15% of checkout failures. We are investigating and will update once we have more information
Posted Jun 15, 2021 - 16:40 PDT
This incident affected: Affirm Checkout (US).