Identified Issue Affecting Phone Support in the US
Incident Report for Affirm
Resolved
The third party has informed us that the issues have been fixed and we have seen our services return to their usual performance.
Posted Sep 28, 2022 - 15:05 PDT
Identified
We have identified issues that are affecting our phone support service in the US. The cause of this is due to the degradation of a third party service we use and we are currently attempting to fix the issue. Please try use email and/or chat if you need to reach customer support at mean time.
Posted Sep 28, 2022 - 11:09 PDT
This incident affected: Support & Customer Service (US).