US & CA Network Maintenance

Scheduled for Jun 30, 22:00 PDT  -  Jul 1, 00:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 27, 2025 - 09:37 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 01, 2025 - 00:00 PDT

Scheduled

On June 30th, 2025, Affirm will be performing updates to its network services in the US and CA. No downtime expected.
Posted Jun 30, 2025 - 22:00 PDT