Temporary Conversion Rate Impact via external Major US Mobile Service outage

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Sep 29, 2025 - 13:16 PDT

Monitoring

We are continuing to monitor a temporary degradation to Affirm US conversion rates between ~8:20 - 8:40 AM PT. User's ability to complete checkout was impacted by a service degradation to a major cell network with significant market share in the US. We have seen recovery and are continuing to confirm the details.
Posted Sep 29, 2025 - 09:02 PDT
This incident affected: Affirm Checkout (US).