Checkout Degradation

Incident Report for Affirm

Resolved

Services have been restored.
Posted Jun 04, 2026 - 02:36 PDT

Update

Services have been restored.
Posted Jun 04, 2026 - 02:35 PDT

Monitoring

A fix has been implemented and we are monitoring recovery.
Posted Jun 04, 2026 - 02:15 PDT

Investigating

The Affirm team has observed degradation in some US checkouts and is currently investigating.
Posted Jun 04, 2026 - 01:01 PDT
This incident affected: Affirm Checkout (US).