Degradation in Affirm UK Checkout

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 10:22 PST

Monitoring

We are currently in a monitoring state.
Posted Dec 11, 2025 - 10:30 PST
This incident affected: Affirm Checkout (UK).