Increased latency across multiple endpionts

Incident Report for Affirm

Resolved

Latencies have returned to normal levels. We will continue to monitor to ensure stability.
Posted Jul 02, 2025 - 19:11 PDT

Monitoring

Our endpoints all look recovered. We will continue to monitor the situation to ensure that our systems are fully operational.
Posted Jul 02, 2025 - 19:05 PDT

Identified

We are seeing recovery, one of our partners is working on full resolution.
Seeing increased latency across multiple partners but impact is limited to the US only.
Posted Jul 02, 2025 - 18:50 PDT

Update

We have identified the cause of the disruption to our services as due to dynamodb. We are currently working closely with the appropiate teams to resolve the issue as quickly as possible.
Posted Jul 02, 2025 - 18:46 PDT

Investigating

We are aware of an issue where increased latency is affecting multiple endpoints and some checkout timeouts. Our team is currently investigating, and we will provide additional updates as soon as possible.
Posted Jul 02, 2025 - 18:25 PDT
This incident affected: Affirm Checkout (US).