Degradation in Affirm Checkout Service

Incident Report for Affirm

Resolved

This incident has been resolved and we are fully recovered.
Posted Dec 05, 2025 - 01:54 PST

Monitoring

We are seeing recovery, but will continue to monitor.
Posted Dec 05, 2025 - 01:15 PST

Identified

We are currently experiencing a degradation in all Affirm API's for users. Our engineering team is working to identify the root cause and implement a solution as soon as possible.
Posted Dec 05, 2025 - 01:04 PST
This incident affected: Affirm Checkout (US, Canada), Affirm Charges API (US, Canada, UK), Affirm.com (US, Canada), Affirm Virtual Card Network (US, Canada, UK), Affirm Mobile App (US, Canada, UK), Affirm Promotional Services (US, Canada, UK), Affirm Purchase API (US, Canada, UK), Affirm Transactions API (US, Canada, UK), US - Platforms / Payment Gateways (US - Shopify Payments App, US - Shop Pay Installments, US - BigCommerce, US - WooCommerce, US - Wix), Affirm Prequalification (US, Canada, UK), CA - Platforms / Payment Gateways (CA - Shopify Payments App), and UK - Platforms / Payment Gateways (UK - Shop Pay Installments).