Affirm Services Degradation

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 15:00 PDT

Monitoring

A fix has been implemented and we are currently seeing recovery and will continue to monitor system performance closely to ensure full stability.
Posted Aug 12, 2026 - 14:39 PDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 12, 2026 - 14:24 PDT

Identified

We are currently experiencing degraded performance across Affirm services. Our engineering team has identified the root cause and is actively working to implement a fix. We will provide another update as soon as the issue is resolved or more information becomes available.
Posted Aug 12, 2026 - 14:12 PDT
This incident affected: Affirm Checkout (US).