Canada users may be unable to signup with Affirm
Incident Report for Affirm
Resolved
The issue has been resolved. Users in Canada are able to sign-up with Affirm.
Posted Dec 02, 2022 - 17:17 PST
Monitoring
We have implemented a fix that we believe will resolve the issue. We will continue to monitor the situation to ensure that our systems are fully operational.
Posted Dec 02, 2022 - 13:25 PST
Update
We are continuing to investigate this issue.
Posted Dec 02, 2022 - 09:15 PST
Update
We have identified that this issue is caused by a third party credit review service, and we are actively working with them to resolve this issue as quickly as possible. We will provide more updates as soon as they are available.
Posted Dec 02, 2022 - 09:14 PST
Investigating
We are aware of an issue where Canada users may be unable to signup with Affirm. Our team is currently investigating, and we will provide additional updates as soon as possible.
Posted Dec 02, 2022 - 06:59 PST
This incident affected: Affirm Checkout (Canada).