Increased Latency in US

Incident Report for Affirm

Resolved

Our services have maintained operational so this incident is now resolved.
Posted Nov 10, 2025 - 09:27 PST

Monitoring

Our teams have mitigated the impact to latency and availability has returned to normal. We will continue monitoring to ensure our services maintain operational.
Posted Nov 10, 2025 - 09:23 PST

Investigating

We are investigating an increase in latency in our checkout flow. We will provide additional updates as soon as possible.
Posted Nov 10, 2025 - 09:11 PST
This incident affected: Affirm Checkout (US).