Merchant Portal Outage

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 10:27 PDT

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 06:47 PDT

Investigating

We are currently investigating an issue affecting the Merchant Portal. Users may be unable to access the portal at this time. Our engineering team is actively working to identify the root cause and restore functionality as quickly as possible. We’ll provide an update as soon as more information is available.
Posted Jun 17, 2025 - 06:46 PDT
This incident affected: Merchant Operations (US).