Affirm Checkout in US/CA has maintained normal success rates. We are continuing to monitor.
Posted Jun 12, 2025 - 13:37 PDT
Update
We see normal success rates for checkout in all countries and domains. Continuing to monitor before considering the issue resolved.
Posted Jun 12, 2025 - 13:08 PDT
Update
We are continuing to monitor for issues with Checkout Service in US/CA. No regression in service health has been observed.
Posted Jun 12, 2025 - 12:57 PDT
Update
We are continuing to monitor the health of Checkout Service in US/CA and have seen no regression in service health.
Posted Jun 12, 2025 - 12:36 PDT
Update
The mitigation applied has been successful at restoring Checkout Service for Affirm merchants. We are continuing to monitor to ensure that service is fully restored.
Posted Jun 12, 2025 - 12:16 PDT
Monitoring
We have implemented a mitigation which is showing some positive impact to impacted services. We are continuing to monitor that impact and will update accordingly.
Posted Jun 12, 2025 - 11:58 PDT
Update
We have updated the status to reflect that Checkout in Canada was impacted to some degree.
Posted Jun 12, 2025 - 11:56 PDT
Identified
We have identified the cause of the outage and are investigating potential mitigations now.
Posted Jun 12, 2025 - 11:43 PDT
Update
We have confirmed that not all merchants are impacted. We are working to delineate exactly who is and is not impacted and will communicate to merchants/partners accordingly.
Posted Jun 12, 2025 - 11:30 PDT
Investigating
We are currently investigating a degradation to checkout and other services in the US
Posted Jun 12, 2025 - 11:17 PDT
This incident affected: Affirm Checkout (US, Canada).