Merchant Portal Sign-in Degradation

Incident Report for Affirm

Resolved

Our team has deployed a fix and have seen the errors subside. All services are now functioning as expected and both URL's are working:
- https://www.affirm.com/dashboard/signin/
- https://www.affirm.ca/dashboard/signin/
Posted Oct 15, 2025 - 11:37 PDT

Update

Merchants attempting to hit the following URLs are receiving an error due to an issue with the trailing slash:
- https://www.affirm.com/dashboard/signin/
- https://www.affirm.ca/dashboard/signin/

While our team works on mitigating this issue, in order to hit the dashboard sign-in page, hit the following Sign-in URLs:
- https://www.affirm.com/dashboard/signin
- https://www.affirm.ca/dashboard/signin
Posted Oct 15, 2025 - 07:29 PDT

Update

We are continuing to investigate this issue.
Posted Oct 15, 2025 - 07:08 PDT

Investigating

We are currently experiencing elevated level of errors that are affecting the Merchant Portal Dashboard, and we are investigating the issue. We will provide additional updates as we know more.
Posted Oct 15, 2025 - 07:08 PDT
This incident affected: Merchant Operations (US, Canada).