Some checkouts experiencing increased latencies.
Incident Report for Affirm
Resolved
Latencies for effected endpoints have returned to normal levels. This issue is now resolved.
Posted Nov 25, 2022 - 13:12 PST
Update
Checkout flow has continued to exhibit high latency for the upper 1% of US checkouts. Because the metrics appear to be recovering, we are monitoring before initiating a deploy to remedy the situation.

Updates pending further developments.
Posted Nov 25, 2022 - 12:44 PST
Monitoring
Some US Affirm users may have experienced increased latencies during checkout flow beginning at 10:30 AM PST. Most traffic is not effected and tail end latencies are decreasing.

We are monitoring Affirm’s performance and are prepared to take mitigating action if performance continues to degrade.
Posted Nov 25, 2022 - 12:01 PST
This incident affected: Affirm Checkout (US).