Increase in Latency Across Affirm APIs

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 21:20 PST

Monitoring

We have not seen a recurrence since approximately 18:20 pm PT and are continuing to monitor our dashboards.
Posted Dec 03, 2025 - 19:05 PST

Identified

We have identified the root cause of the service disruption and are actively working on a mitigation.
Posted Dec 03, 2025 - 18:36 PST

Investigating

We are investigating increased API error rates in the US-EAST-1 Region.
Posted Dec 03, 2025 - 18:19 PST
This incident affected: Affirm Checkout (US), Affirm Purchase API (US), Affirm Transactions API (US), and US - Platforms / Payment Gateways (US - Shop Pay Installments).