US SMS Authentication Service Degraded

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 09:31 PDT

Monitoring

We were able to cutover traffic to a recovered SMS service and have observed recovery. We will continue to monitor before resolving the incident.
Posted Apr 17, 2026 - 22:37 PDT

Update

PIN retry rates for users in US remain unchanged. There is a central point of failure effecting multiple 3rd party SMS providers. Users who retry are successfully completing checkouts. We will continue to monitor the situation and update as it progresses.
Posted Apr 17, 2026 - 21:15 PDT

Update

We are still observing elevated PIN retry rates for users in US. There is a central point of failure effecting multiple 3rd party SMS providers. Users who retry are successfully completing checkouts. We will continue to monitor the situation and update as it progresses.
Posted Apr 17, 2026 - 20:03 PDT

Identified

We have identified the cause of the SMS retry rate and are investigating potential mitigations.
Posted Apr 17, 2026 - 19:43 PDT

Investigating

We are currently investigating an increase in our SMS PIN retry rate affecting Affirm Checkout in the US
Posted Apr 17, 2026 - 19:15 PDT
This incident affected: Affirm Checkout (US).