US/CA Database Maintenance

Scheduled for Jun 10, 23:00 PDT  -  Jun 11, 02:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 29, 2026 - 13:55 PDT

Scheduled

On June 10th, 2026, Affirm will be perform updates to nine of its database clusters in the US and CA. Affirm Checkout Critical databases may experience a downtime of up to 1 minute each.

The maintenance will begin at 11:00 PM PT on 06/10/2026 and end at 2:00 AM PT on 06/11/2026. The expected aggregate downtime is estimated to be, at most, 9 minutes for the US and 1 minute for CA within this 3 hour window.
Posted May 28, 2026 - 12:11 PDT
This scheduled maintenance affects: Affirm Checkout (US, Canada), Affirm Charges API (US, Canada), Affirm Virtual Card Network (US, Canada), Affirm Promotional Services (US, Canada), Affirm Purchase API (US, Canada), and Affirm Transactions API (US, Canada).