Checkout Degradation for Affirm Lease-to-Own
Incident Report for Affirm
Resolved
Our team has deployed a fix for Affirm's Lease-to-Own checkout and all services are now functioning as expected.
Posted Jun 13, 2022 - 15:49 PDT
Identified
We are aware of an issue that may prevent some users from checking out using Affirm's Lease-to-Own option. We have identified the cause of the disruption, and are currently attempting to fix the issue. We will provide more updates as soon as they are available.
Posted Jun 13, 2022 - 15:42 PDT
This incident affected: Affirm Checkout (US).