Degraded checkout performance with identity verification
Incident Report for Affirm
Resolved
This incident has been resolved.
Posted Nov 29, 2023 - 02:01 PST
Identified
We're currently experiencing an issue with our identity verification systems impacting our checkout flows slightly degrading performance. We've already identified the issue and are proactively working on a fix.
Posted Nov 29, 2023 - 01:31 PST
This incident affected: Affirm Checkout (US, Canada).