Checkout Degradation

Incident Report for Affirm

Resolved

The checkout flow degradation caused by our CDN provider has been resolved. Our teams have confirmed full recovery and normal service has resumed.
Posted Jun 22, 2026 - 08:06 PDT

Monitoring

We have seen a degradation to our checkout flow as a result of our CDN provider and believe that it has been mitigated. Our teams are continuing to monitor before confirming full recovery.
Posted Jun 22, 2026 - 07:36 PDT
This incident affected: Affirm Checkout (US).