Merchant Dashboard Login Degradation

Incident Report for Affirm

Resolved

The login functionality has maintained functional and the merchant dashboard is fully functional. This incident is now resolved.
Posted Aug 28, 2025 - 15:51 PDT

Update

The fix has been deployed and login functionality of the merchant dashboard has been restored. We will continue monitoring this before resolving.
Posted Aug 28, 2025 - 13:13 PDT

Identified

We have identified the root cause of the issue and are working on implementing a fix.
Posted Aug 28, 2025 - 07:45 PDT

Update

Our teams are still working on identifying the root cause of the issue.
Posted Aug 27, 2025 - 17:20 PDT

Investigating

Some merchants may experience issues when logging into their merchant dashboards with MFA. Our teams are working on confirming the root cause of the issue and mitigating the impact. We will update as soon as possible.
Posted Aug 27, 2025 - 13:29 PDT
This incident affected: Merchant Operations (US).