Affirm API endpoints may be affected by latency degradation.

Incident Report for Affirm

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 12:56 PDT

Monitoring

The issue affected our Cloud Edge Provider. They have implemented a fix and we are observing latency coming back to baseline.
Posted Aug 21, 2025 - 11:54 PDT

Investigating

We are investigating an issue that is affecting latency of Affirm endpoints.
Posted Aug 21, 2025 - 11:06 PDT
This incident affected: Affirm Checkout (US, Canada), Affirm Promotional Services (US, Canada), Affirm Purchase API (US, Canada), Affirm Transactions API (US, Canada), US - Platforms / Payment Gateways (US - Shopify Payments App, US - Shop Pay Installments, US - BigCommerce, US - WooCommerce, US - Wix, US - Other), Affirm Prequalification (US, Canada), and CA - Platforms / Payment Gateways (CA - Shopify Payments App).