We are implementing a permanent fix to the mitigated issue. Checkout activity remains healthy. We will monitor the results and resolve the incident once efficacy of said fix has been confirmed.
Posted Mar 04, 2026 - 18:03 PST
Update
Affirm's systems remain stable and we are making progress determining root cause. More updates will come shortly.
Posted Mar 04, 2026 - 17:15 PST
Update
We have maintained normal availability since the mitigation. We are continuing to dig into root causes on this issue.
Posted Mar 04, 2026 - 16:38 PST
Monitoring
We have maintained normal availability since the mitigation. We are continuing to dig into root causes on this issue.
Posted Mar 04, 2026 - 16:06 PST
Identified
We have performed a mitigation and have observed checkout availability recovery for all merchants. We will monitor to ensure stability.
Posted Mar 04, 2026 - 15:47 PST
Investigating
We are currently investigating a degradation to loan authorization rate, indicating an issue in the checkout flow. We will update with new findings as soon as possible
Posted Mar 04, 2026 - 15:36 PST
This incident affected: Affirm Checkout (US, Canada).