Affirm Canada Checkout Disruption
Incident Report for Affirm
Resolved
The issues within the Affirm checkout flow have been mitigated. We will continue to monitor the situation and relay any relevant communications to our status page.
Posted Nov 17, 2021 - 17:58 PST
Investigating
We’re currently experiencing a degradation in our checkout service. Our engineering team is working to identify the root cause and implement a solution as soon as possible.
Posted Nov 17, 2021 - 17:38 PST
This incident affected: Affirm Checkout (Canada).