Impact to all traffic

Incident Report for Affirm

Resolved

This issue has been resolved and full service has been restored
Posted Nov 18, 2025 - 07:28 PST

Monitoring

Service is being restored and we expect full resolution shortly.
Posted Nov 18, 2025 - 06:48 PST

Identified

Our teams have confirmed that the degradation is a result of a widespread issue impacting a core infrastructure provider. We are monitoring the situation closely and will update in the next 30 minutes.
Posted Nov 18, 2025 - 06:08 PST

Investigating

We are investigating a sudden drop in all successful traffic to Affirm services in the US, CA and UK
Posted Nov 18, 2025 - 06:07 PST
This incident affected: Affirm Checkout (US, Canada, UK).