A small number of user loans incorrectly charged
Incident Report for Affirm
Resolved
This incident only affected a small handful of loans and was due to an issue that the payment processor has resolved
Posted Feb 16, 2024 - 16:26 PST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2024 - 16:21 PST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2024 - 15:23 PST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2024 - 10:42 PST
Update
We are continuing to investigate this issue.
Posted Feb 16, 2024 - 08:49 PST
Investigating
We are currently investigating this issue.
Posted Feb 16, 2024 - 08:22 PST
This incident affected: Merchant Operations (US) and US - Platforms / Payment Gateways (US - Other).