Increase in Latency Across Affirm APIs

Incident Report for Affirm

Resolved

This incident is resolved now.
Posted Dec 03, 2025 - 12:02 PST

Monitoring

We are seeing recovery across all endpoints - we will keep monitoring for full resolution.
Posted Dec 03, 2025 - 11:02 PST

Identified

We identified what's causing this increased API error rates in the US-EAST-1 Region and currently working to mitigate.
Posted Dec 03, 2025 - 10:19 PST

Investigating

We are investigating increased API error rates in the US-EAST-1 Region.
Posted Dec 03, 2025 - 10:18 PST
This incident affected: Affirm Checkout (US), Affirm Purchase API (US), Affirm Transactions API (US), and US - Platforms / Payment Gateways (US - Shop Pay Installments).