latency

Incident Report for Affirm

Resolved

The latency was related to a disruption on a core infrastructure provider. We are observing full recovery.
Posted Nov 18, 2025 - 09:30 PST

Investigating

We have detected intermittent API latency and are actively investigating.
Posted Nov 18, 2025 - 09:11 PST
This incident affected: Affirm Transactions API (US, Canada).