Customers are unable to reach Canada customer service number

Incident Report for Affirm

Resolved

All services are now functioning as expected.
Posted Aug 06, 2024 - 10:04 PDT

Identified

We have identified the cause and are continuing to work on a fix for the customer service call center disruption.
Posted Aug 06, 2024 - 09:02 PDT

Investigating

We are currently investigating the issue.
Posted Aug 06, 2024 - 08:54 PDT